re = /^(?:(?!^\s|\s$)[a-z0-9\s]){1,20}$/mi
str = '12345678901234567890
12345678901234567890foo
12345
12345 12345
12345
a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end