const regex = /^(?:(?!^\s|\s$)[a-z0-9\s]){1,20}$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?!^\\s|\\s$)[a-z0-9\\s]){1,20}$', 'gmi')
const str = `12345678901234567890
12345678901234567890foo
12345
12345 12345
12345
a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}