import re
regex = re.compile(r"^(?:(?!^\s|\s$)[a-z0-9\s]){1,20}$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("12345678901234567890\n"
"12345678901234567890foo\n"
" 12345\n"
"12345 12345\n"
"12345 \n"
"a")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")