#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https:\/\/(www.|nysinternships.)?cs.ny.gov\/(?!(([a-z]*\/)*(cal_db\.cfm\?date=|list\.cfm\?Exam=|scheduler\?monthyear=))).*"
Local $sString = "https://careermobilityoffice.cs.ny.gov/cmo/merit-system.cfm" & @CRLF & _
"https://careermobilityoffice.cs.ny.gov/" & @CRLF & _
"https://cs.ny.gov/" & @CRLF & _
"https://www.cs.ny.gov/" & @CRLF & _
"https://nysinternships.cs.ny.gov/" & @CRLF & _
"https://nysinternships.cs.ny.gov/forms/faq.html?date=blah" & @CRLF & _
"https://nysinternships.cs.ny.gov/forms/cal_db.cfm?date=blah" & @CRLF & _
"https://nysinternships.cs.ny.gov/list.cfm?Exam=blah" & @CRLF & _
"https://nysinternships.cs.ny.gov/forms/pdf/scheduler?monthyear=blah" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")