import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/(www.|nysinternships.)?cs.ny.gov\\/(?!(([a-z]*\\/)*(cal_db\\.cfm\\?date=|list\\.cfm\\?Exam=|scheduler\\?monthyear=))).*";
final String string = "https://careermobilityoffice.cs.ny.gov/cmo/merit-system.cfm\n"
+ "https://careermobilityoffice.cs.ny.gov/\n"
+ "https://cs.ny.gov/\n"
+ "https://www.cs.ny.gov/\n"
+ "https://nysinternships.cs.ny.gov/\n"
+ "https://nysinternships.cs.ny.gov/forms/faq.html?date=blah\n"
+ "https://nysinternships.cs.ny.gov/forms/cal_db.cfm?date=blah\n"
+ "https://nysinternships.cs.ny.gov/list.cfm?Exam=blah\n"
+ "https://nysinternships.cs.ny.gov/forms/pdf/scheduler?monthyear=blah\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}