using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/(www.|nysinternships.)?cs.ny.gov\/(?!(([a-z]*\/)*(cal_db\.cfm\?date=|list\.cfm\?Exam=|scheduler\?monthyear=))).*";
string input = @"https://careermobilityoffice.cs.ny.gov/cmo/merit-system.cfm
https://careermobilityoffice.cs.ny.gov/
https://cs.ny.gov/
https://www.cs.ny.gov/
https://nysinternships.cs.ny.gov/
https://nysinternships.cs.ny.gov/forms/faq.html?date=blah
https://nysinternships.cs.ny.gov/forms/cal_db.cfm?date=blah
https://nysinternships.cs.ny.gov/list.cfm?Exam=blah
https://nysinternships.cs.ny.gov/forms/pdf/scheduler?monthyear=blah
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}