$re = '/https:\/\/(www.|nysinternships.)?cs.ny.gov\/(?!(([a-z]*\/)*(cal_db\.cfm\?date=|list\.cfm\?Exam=|scheduler\?monthyear=))).*/m';
$str = 'https://careermobilityoffice.cs.ny.gov/cmo/merit-system.cfm
https://careermobilityoffice.cs.ny.gov/
https://cs.ny.gov/
https://www.cs.ny.gov/
https://nysinternships.cs.ny.gov/
https://nysinternships.cs.ny.gov/forms/faq.html?date=blah
https://nysinternships.cs.ny.gov/forms/cal_db.cfm?date=blah
https://nysinternships.cs.ny.gov/list.cfm?Exam=blah
https://nysinternships.cs.ny.gov/forms/pdf/scheduler?monthyear=blah
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);