import Foundation
let pattern = #"https:\/\/(www.|nysinternships.)?cs.ny.gov\/(?!(([a-z]*\/)*(cal_db\.cfm\?date=|list\.cfm\?Exam=|scheduler\?monthyear=))).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://careermobilityoffice.cs.ny.gov/cmo/merit-system.cfm
https://careermobilityoffice.cs.ny.gov/
https://cs.ny.gov/
https://www.cs.ny.gov/
https://nysinternships.cs.ny.gov/
https://nysinternships.cs.ny.gov/forms/faq.html?date=blah
https://nysinternships.cs.ny.gov/forms/cal_db.cfm?date=blah
https://nysinternships.cs.ny.gov/list.cfm?Exam=blah
https://nysinternships.cs.ny.gov/forms/pdf/scheduler?monthyear=blah
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)