use strict;
my $str = 'https://careermobilityoffice.cs.ny.gov/cmo/merit-system.cfm
https://careermobilityoffice.cs.ny.gov/
https://cs.ny.gov/
https://www.cs.ny.gov/
https://nysinternships.cs.ny.gov/
https://nysinternships.cs.ny.gov/forms/faq.html?date=blah
https://nysinternships.cs.ny.gov/forms/cal_db.cfm?date=blah
https://nysinternships.cs.ny.gov/list.cfm?Exam=blah
https://nysinternships.cs.ny.gov/forms/pdf/scheduler?monthyear=blah
';
my $regex = qr/https:\/\/(www.|nysinternships.)?cs.ny.gov\/(?!(([a-z]*\/)*(cal_db\.cfm\?date=|list\.cfm\?Exam=|scheduler\?monthyear=))).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}