const regex = /([a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\\.[a-zA-Z0-9-.]+)', 'g')
const str = `["durov@telegram.org","active","available","2015-02-12 14:14:54","00.000.00.000","","0.0.0.0","1111114","2014-05-12 18:00:00","","","","","","0.0.0.0","","","","","Pavel","Durov",""]
["admin@sd.com","active","available","2015-02-12 14:14:54","00.000.00.000","","0.0.0.0","1111114","2014-05-12 18:00:00","","","","","","0.0.0.0","","","","","Thank","You",""]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}