// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+)").unwrap();
let string = "[\"durov@telegram.org\",\"active\",\"available\",\"2015-02-12 14:14:54\",\"00.000.00.000\",\"\",\"0.0.0.0\",\"1111114\",\"2014-05-12 18:00:00\",\"\",\"\",\"\",\"\",\"\",\"0.0.0.0\",\"\",\"\",\"\",\"\",\"Pavel\",\"Durov\",\"\"]
[\"admin@sd.com\",\"active\",\"available\",\"2015-02-12 14:14:54\",\"00.000.00.000\",\"\",\"0.0.0.0\",\"1111114\",\"2014-05-12 18:00:00\",\"\",\"\",\"\",\"\",\"\",\"0.0.0.0\",\"\",\"\",\"\",\"\",\"Thank\",\"You\",\"\"]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}