#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*)[^a-zA-Z0-9]"
Local $sString = "test1" & @CRLF & _
"test" & @CRLF & _
"tester" & @CRLF & _
"tester,3" & @CRLF & _
"tester,48g" & @CRLF & _
"testsd3er_"
Local $sSubst = "$1\r\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)