const regex = /(.*)[^a-zA-Z0-9]/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)[^a-zA-Z0-9]', 'mg')
const str = `test1
test
tester
tester,3
tester,48g
testsd3er_`;
const subst = `$1\r\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);