import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)[^a-zA-Z0-9]";
final String string = "test1\n"
+ "test\n"
+ "tester\n"
+ "tester,3\n"
+ "tester,48g\n"
+ "testsd3er_";
final String subst = "$1\\r\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}