$re = '/(.*)[^a-zA-Z0-9]/m';
$str = 'test1
test
tester
tester,3
tester,48g
testsd3er_';
$subst = "$1\r\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;