using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)[^a-zA-Z0-9]";
string substitution = @"$1\r\n";
string input = @"test1
test
tester
tester,3
tester,48g
testsd3er_";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}