package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(season|s)\s*(\d+)(episode|e|x)\s*(\d+)`)
var str = `Hello seinfeld season 01episode 22 foo bar
s 01e 02
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}