$re = '/\s*(season|s)\s*(\d+)(episode|e|x)\s*(\d+)/m';
$str = 'Hello seinfeld season 01episode 22 foo bar
s 01e 02
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);