re = /\s*(season|s)\s*(\d+)(episode|e|x)\s*(\d+)/m
str = 'Hello seinfeld season 01episode 22 foo bar
s 01e 02
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end