// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*(season|s)\s*(\d+)(episode|e|x)\s*(\d+)").unwrap();
let string = "Hello seinfeld season 01episode 22 foo bar
s 01e 02
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}