const regex = new RegExp('\\s*(season|s)\\s*(\\d+)(episode|e|x)\\s*(\\d+)', 'gm')
const str = `Hello seinfeld season 01episode 22 foo bar
s 01e 02
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}