package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[15-Nov\-2019 [\d:]+ UTC\] PHP Notice: wpdb::prepare was called <strong>incorrectly<\/strong>\. The query does not contain the correct number of placeholders \(0\) for the number of arguments passed \(1\)\. Please see <a href="https:\/\/wordpress\.org\/support\/article\/debugging-in-wordpress\/">Debugging in WordPress<\/a> for more information\. \(This message was added in version 4\.8\.3\.\) in \/var\/www\/html\/blog\.nssl\.noaa\.gov\/wp-includes\/functions\.php on line 4903`)
var str = `[15-Nov-2019 06:00:01 UTC] PHP Notice: wpdb::prepare was called <strong>incorrectly</strong>. The query does not contain the correct number of placeholders (0) for the number of arguments passed (1). Please see <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Debugging in WordPress</a> for more information. (This message was added in version 4.8.3.) in /var/www/html/blog.nssl.noaa.gov/wp-includes/functions.php on line 4903`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}