import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[15-Nov\\-2019 [\\d:]+ UTC\\] PHP Notice: wpdb::prepare was called <strong>incorrectly<\\/strong>\\. The query does not contain the correct number of placeholders \\(0\\) for the number of arguments passed \\(1\\)\\. Please see <a href=\"https:\\/\\/wordpress\\.org\\/support\\/article\\/debugging-in-wordpress\\/\">Debugging in WordPress<\\/a> for more information\\. \\(This message was added in version 4\\.8\\.3\\.\\) in \\/var\\/www\\/html\\/blog\\.nssl\\.noaa\\.gov\\/wp-includes\\/functions\\.php on line 4903";
final String string = "[15-Nov-2019 06:00:01 UTC] PHP Notice: wpdb::prepare was called <strong>incorrectly</strong>. The query does not contain the correct number of placeholders (0) for the number of arguments passed (1). Please see <a href=\"https://wordpress.org/support/article/debugging-in-wordpress/\">Debugging in WordPress</a> for more information. (This message was added in version 4.8.3.) in /var/www/html/blog.nssl.noaa.gov/wp-includes/functions.php on line 4903";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}