import Foundation
let pattern = #"\[15-Nov\-2019 [\d:]+ UTC\] PHP Notice: wpdb::prepare was called <strong>incorrectly<\/strong>\. The query does not contain the correct number of placeholders \(0\) for the number of arguments passed \(1\)\. Please see <a href="https:\/\/wordpress\.org\/support\/article\/debugging-in-wordpress\/">Debugging in WordPress<\/a> for more information\. \(This message was added in version 4\.8\.3\.\) in \/var\/www\/html\/blog\.nssl\.noaa\.gov\/wp-includes\/functions\.php on line 4903"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[15-Nov-2019 06:00:01 UTC] PHP Notice: wpdb::prepare was called <strong>incorrectly</strong>. The query does not contain the correct number of placeholders (0) for the number of arguments passed (1). Please see <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Debugging in WordPress</a> for more information. (This message was added in version 4.8.3.) in /var/www/html/blog.nssl.noaa.gov/wp-includes/functions.php on line 4903"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)