# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[15-Nov\-2019 [\d:]+ UTC\] PHP Notice: wpdb::prepare was called <strong>incorrectly<\/strong>\. The query does not contain the correct number of placeholders \(0\) for the number of arguments passed \(1\)\. Please see <a href=\"https:\/\/wordpress\.org\/support\/article\/debugging-in-wordpress\/\">Debugging in WordPress<\/a> for more information\. \(This message was added in version 4\.8\.3\.\) in \/var\/www\/html\/blog\.nssl\.noaa\.gov\/wp-includes\/functions\.php on line 4903"
test_str = "[15-Nov-2019 06:00:01 UTC] PHP Notice: wpdb::prepare was called <strong>incorrectly</strong>. The query does not contain the correct number of placeholders (0) for the number of arguments passed (1). Please see <a href=\"https://wordpress.org/support/article/debugging-in-wordpress/\">Debugging in WordPress</a> for more information. (This message was added in version 4.8.3.) in /var/www/html/blog.nssl.noaa.gov/wp-includes/functions.php on line 4903"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.