use strict;
my $str = '[15-Nov-2019 06:00:01 UTC] PHP Notice: wpdb::prepare was called <strong>incorrectly</strong>. The query does not contain the correct number of placeholders (0) for the number of arguments passed (1). Please see <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Debugging in WordPress</a> for more information. (This message was added in version 4.8.3.) in /var/www/html/blog.nssl.noaa.gov/wp-includes/functions.php on line 4903';
my $regex = qr/\[15-Nov\-2019 [\d:]+ UTC\] PHP Notice: wpdb::prepare was called <strong>incorrectly<\/strong>\. The query does not contain the correct number of placeholders \(0\) for the number of arguments passed \(1\)\. Please see <a href="https:\/\/wordpress\.org\/support\/article\/debugging-in-wordpress\/">Debugging in WordPress<\/a> for more information\. \(This message was added in version 4\.8\.3\.\) in \/var\/www\/html\/blog\.nssl\.noaa\.gov\/wp-includes\/functions\.php on line 4903/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}