const regex = /\[15-Nov\-2019 [\d:]+ UTC\] PHP Notice: wpdb::prepare was called <strong>incorrectly<\/strong>\. The query does not contain the correct number of placeholders \(0\) for the number of arguments passed \(1\)\. Please see <a href="https:\/\/wordpress\.org\/support\/article\/debugging-in-wordpress\/">Debugging in WordPress<\/a> for more information\. \(This message was added in version 4\.8\.3\.\) in \/var\/www\/html\/blog\.nssl\.noaa\.gov\/wp-includes\/functions\.php on line 4903/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[15-Nov\\-2019 [\\d:]+ UTC\\] PHP Notice: wpdb::prepare was called <strong>incorrectly<\\\/strong>\\. The query does not contain the correct number of placeholders \\(0\\) for the number of arguments passed \\(1\\)\\. Please see <a href="https:\\\/\\\/wordpress\\.org\\\/support\\\/article\\\/debugging-in-wordpress\\\/">Debugging in WordPress<\\\/a> for more information\\. \\(This message was added in version 4\\.8\\.3\\.\\) in \\\/var\\\/www\\\/html\\\/blog\\.nssl\\.noaa\\.gov\\\/wp-includes\\\/functions\\.php on line 4903', 'gm')
const str = `[15-Nov-2019 06:00:01 UTC] PHP Notice: wpdb::prepare was called <strong>incorrectly</strong>. The query does not contain the correct number of placeholders (0) for the number of arguments passed (1). Please see <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Debugging in WordPress</a> for more information. (This message was added in version 4.8.3.) in /var/www/html/blog.nssl.noaa.gov/wp-includes/functions.php on line 4903`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}