using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"d\/(\w+)\?rel=\d+""";
string input = @"<iframe width=""560"" height=""315"" src=""//www.youtube.com/embed/0gugBiEkLwU?rel=0"" frameborder=""0"" allowfullscreen></iframe> ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}