const regex = /d\/(\w+)\?rel=\d+"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('d\\\/(\\w+)\\?rel=\\d+"', '')
const str = `<iframe width="560" height="315" src="//www.youtube.com/embed/0gugBiEkLwU?rel=0" frameborder="0" allowfullscreen></iframe> `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}