re = /d\/(\w+)\?rel=\d+"/
str = '<iframe width="560" height="315" src="//www.youtube.com/embed/0gugBiEkLwU?rel=0" frameborder="0" allowfullscreen></iframe> '
# Print the match result
str.match(re) do |match|
puts match.to_s
end