package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`d\/(\w+)\?rel=\d+"`)
var str = `<iframe width="560" height="315" src="//www.youtube.com/embed/0gugBiEkLwU?rel=0" frameborder="0" allowfullscreen></iframe> `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}