import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "d\\/(\\w+)\\?rel=\\d+\"";
final String string = "<iframe width=\"560\" height=\"315\" src=\"//www.youtube.com/embed/0gugBiEkLwU?rel=0\" frameborder=\"0\" allowfullscreen></iframe> ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}