// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"d\/(\w+)\?rel=\d+""#).unwrap();
let string = "<iframe width=\"560\" height=\"315\" src=\"//www.youtube.com/embed/0gugBiEkLwU?rel=0\" frameborder=\"0\" allowfullscreen></iframe> ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}