# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=^[\d.]{5}).+(?=_rev)|rev//gm;t' <<< "45.092222 - WrapperA12_rev1.DXF"