import re
regex = re.compile(r"(?<=^[\d.]{5}).+(?=_rev)|rev", flags=re.MULTILINE)
test_str = "45.092222 - WrapperA12_rev1.DXF"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)