import Foundation
let pattern = #"(?<=^[\d.]{5}).+(?=_rev)|rev"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"45.092222 - WrapperA12_rev1.DXF"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)