const regex = new RegExp('(?<=^[\\d.]{5}).+(?=_rev)|rev', 'gm')
const str = `45.092222 - WrapperA12_rev1.DXF`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);