use strict;
my $str = '45.092222 - WrapperA12_rev1.DXF';
my $regex = qr/(?<=^[\d.]{5}).+(?=_rev)|rev/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";