$re = '/(?<=^[\d.]{5}).+(?=_rev)|rev/m';
$str = '45.092222 - WrapperA12_rev1.DXF';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;