import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^>]+>";
final String string = "<html><body><span style=3D\"font-family:Verdana; color:#000; font-size:10pt;=\n"
+ "\"><div><font face=3D\"verdana, geneva\" size=3D\"2\">http://72.55.146.142:8880/=\n"
+ "order003.png.zip,120<html>test<abc>test2<adg></body></html>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}