# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<[^>]+>"
test_str = ("<html><body><span style=3D\"font-family:Verdana; color:#000; font-size:10pt;=\n"
"\"><div><font face=3D\"verdana, geneva\" size=3D\"2\">http://72.55.146.142:8880/=\n"
"order003.png.zip,120<html>test<abc>test2<adg></body></html>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.