#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d+),(\d+)"
Local $sString = "test() test 12,01% test (12,4) 12.3 s 2 some other text, other text, 2,text"
Local $sSubst = "$1.$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)