use strict;
my $str = 'test() test 12,01% test (12,4) 12.3 s 2 some other text, other text, 2,text';
my $regex = qr/(\d+),(\d+)/p;
my $subst = '$1.$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";