package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+),(\d+)`)
var str = `test() test 12,01% test (12,4) 12.3 s 2 some other text, other text, 2,text`
var substitution = "$1.$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}