using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+),(\d+)";
string substitution = @"$1.$2";
string input = @"test() test 12,01% test (12,4) 12.3 s 2 some other text, other text, 2,text";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}