import Foundation
let pattern = #"(\d+),(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"test() test 12,01% test (12,4) 12.3 s 2 some other text, other text, 2,text"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)