$re = '/(\d+),(\d+)/';
$str = 'test() test 12,01% test (12,4) 12.3 s 2 some other text, other text, 2,text';
$subst = "$1.$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;