#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\$(.*):([^$]*)"
Local $sString = "$Label1: Text1" & @CRLF & _
" Text1 possibly continues " & @CRLF & _
"$Label2: Text2" & @CRLF & _
"$Label3: Text3 " & @CRLF & _
" Text3 possibly continues"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")