const regex = /\$(.*):([^$]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$(.*):([^$]*)', 'g')
const str = `\$Label1: Text1
Text1 possibly continues
\$Label2: Text2
\$Label3: Text3
Text3 possibly continues`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}