re = /\$(.*):([^$]*)/
str = '$Label1: Text1
Text1 possibly continues
$Label2: Text2
$Label3: Text3
Text3 possibly continues'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end